I’ve recently bumped into a problem with using a SSL Network Extender when trying to establish a VPN connection through the web browser.

The SNX was throwing a ‘failed to initialize’ error without any details despite the right credentials.
To identify the error, I needed to execute the snx from the command line (snx) which points that the SNX is missing a libstdc++.so.5. I had a libstdc++.so.6 installed at that point.

In the Ubuntu repositories, there wasn’t anything earlier than libstdc++6, so the only solution I found, was to download version 5 from this site (version for 32 bits).

After installing this package, the snx (both – from the command line and from the web browser) worked just fine.

Did you like this? Share it:

Leave a reply

required


*

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>